From: David Gow <davidgow@google.com>
To: Andrew Morton <akpm@linux-foundation.org>,
	Shuah Khan <skhan@linuxfoundation.org>,
	 Rae Moar <rmoar@google.com>, Kees Cook <kees@kernel.org>,
	 Geert Uytterhoeven <geert@linux-m68k.org>
Cc: Luis Felipe Hernandez <luis.hernandez093@gmail.com>,
	linux-kselftest@vger.kernel.org,  kunit-dev@googlegroups.com,
	linux-kernel@vger.kernel.org,
	 Stephen Rothwell <sfr@canb.auug.org.au>,
	Andy Shevchenko <andy@kernel.org>,
	 Brendan Higgins <brendan.higgins@linux.dev>,
	Nicolas Pitre <npitre@baylibre.com>,
	 David Gow <davidgow@google.com>
Subject: [PATCH v2 1/6] lib: math: Move kunit tests into tests/ subdir
Date: Mon,  2 Dec 2024 15:55:38 +0800	[thread overview]
Message-ID: <20241202075545.3648096-2-davidgow@google.com> (raw)
In-Reply-To: <20241202075545.3648096-1-davidgow@google.com>

From: Luis Felipe Hernandez <luis.hernandez093@gmail.com>

This patch is a follow-up task from a discussion stemming from point 3
in a recent patch introducing the int_pow kunit test [1] and
documentation regarding kunit test style and nomenclature [2].

Colocate all kunit test suites in lib/math/tests/ and
follow recommended naming convention for files <suite>_kunit.c
and kconfig entries CONFIG_<name>_KUNIT_TEST.

Link: https://lore.kernel.org/all/CABVgOS=-vh5TqHFCq_jo=ffq8v_nGgr6JsPnOZag3e6+19ysxQ@mail.gmail.com/ [1]
Link: https://docs.kernel.org/dev-tools/kunit/style.html [2]

Signed-off-by: Luis Felipe Hernandez <luis.hernandez093@gmail.com>
Acked-by: Nicolas Pitre <npitre@baylibre.com>
[Rebased on top of v6.13-rc1, removed non-kunit tests]
Signed-off-by: David Gow <davidgow@google.com>
---
 lib/Kconfig.debug                                    | 2 +-
 lib/math/Makefile                                    | 4 ++--
 lib/math/tests/Makefile                              | 3 ++-
 lib/math/{rational-test.c => tests/rational_kunit.c} | 0
 4 files changed, 5 insertions(+), 4 deletions(-)
 rename lib/math/{rational-test.c => tests/rational_kunit.c} (100%)

diff --git a/lib/Kconfig.debug b/lib/Kconfig.debug
index f3d723705879..7b90948666bf 100644
--- a/lib/Kconfig.debug
+++ b/lib/Kconfig.debug
@@ -3145,7 +3145,7 @@ config TEST_OBJPOOL
 
 	  If unsure, say N.
 
-config INT_POW_TEST
+config INT_POW_KUNIT_TEST
 	tristate "Integer exponentiation (int_pow) test" if !KUNIT_ALL_TESTS
 	depends on KUNIT
 	default KUNIT_ALL_TESTS
diff --git a/lib/math/Makefile b/lib/math/Makefile
index 3ef11305f8d2..d1caba23baa0 100644
--- a/lib/math/Makefile
+++ b/lib/math/Makefile
@@ -5,7 +5,7 @@ obj-$(CONFIG_CORDIC)		+= cordic.o
 obj-$(CONFIG_PRIME_NUMBERS)	+= prime_numbers.o
 obj-$(CONFIG_RATIONAL)		+= rational.o
 
-obj-$(CONFIG_INT_POW_TEST)  += tests/int_pow_kunit.o
 obj-$(CONFIG_TEST_DIV64)	+= test_div64.o
 obj-$(CONFIG_TEST_MULDIV64)	+= test_mul_u64_u64_div_u64.o
-obj-$(CONFIG_RATIONAL_KUNIT_TEST) += rational-test.o
+
+obj-y += tests/
diff --git a/lib/math/tests/Makefile b/lib/math/tests/Makefile
index 6a169123320a..8ce8040e00c5 100644
--- a/lib/math/tests/Makefile
+++ b/lib/math/tests/Makefile
@@ -1,3 +1,4 @@
 # SPDX-License-Identifier: GPL-2.0-only
 
-obj-$(CONFIG_INT_POW_TEST) += int_pow_kunit.o
+obj-$(CONFIG_INT_POW_KUNIT_TEST)  += int_pow_kunit.o
+obj-$(CONFIG_RATIONAL_KUNIT_TEST) += rational_kunit.o
diff --git a/lib/math/rational-test.c b/lib/math/tests/rational_kunit.c
similarity index 100%
rename from lib/math/rational-test.c
rename to lib/math/tests/rational_kunit.c
-- 
2.47.0.338.g60cca15819-goog


  reply	other threads:[~2024-12-02  7:55 UTC|newest]

Thread overview: 10+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2024-12-02  7:55 [PATCH v2 0/6] [PATCH 0/6] KUnit test moves / renames David Gow
2024-12-02  7:55 ` David Gow [this message]
2024-12-02  7:55 ` [PATCH v2 2/6] lib/math: Add int_log test suite David Gow
2024-12-02  7:55 ` [PATCH v2 3/6] lib: Move KUnit tests into tests/ subdirectory David Gow
2024-12-02  7:55 ` [PATCH v2 4/6] lib/tests/kfifo_kunit.c: add tests for the kfifo structure David Gow
2024-12-02  7:55 ` [PATCH v2 5/6] unicode: kunit: refactor selftest to kunit tests David Gow
2024-12-02  7:55 ` [PATCH v2 6/6] unicode: kunit: change tests filename and path David Gow
2024-12-02 16:01 ` [PATCH v2 0/6] [PATCH 0/6] KUnit test moves / renames Andy Shevchenko
2024-12-02 23:29 ` Rae Moar
  -- strict thread matches above, loose matches on Subject: below --
2025-02-11  0:31 [PATCH v2 " Kees Cook
2025-02-11  0:31 ` [PATCH v2 1/6] lib: math: Move KUnit tests into tests/ subdir Kees Cook

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20241202075545.3648096-2-davidgow@google.com \
    --to=davidgow@google.com \
    --cc=akpm@linux-foundation.org \
    --cc=andy@kernel.org \
    --cc=brendan.higgins@linux.dev \
    --cc=geert@linux-m68k.org \
    --cc=kees@kernel.org \
    --cc=kunit-dev@googlegroups.com \
    --cc=linux-kernel@vger.kernel.org \
    --cc=linux-kselftest@vger.kernel.org \
    --cc=luis.hernandez093@gmail.com \
    --cc=npitre@baylibre.com \
    --cc=rmoar@google.com \
    --cc=sfr@canb.auug.org.au \
    --cc=skhan@linuxfoundation.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.